Wed, 30 Sep 2026 06:23:39 CST | login

Information for build bouncycastle-1.80-5.oc9

ID47987
Package Namebouncycastle
Version1.80
Release5.oc9
Epoch
DraftFalse
Sourcegit+https://gitee.com/src-opencloudos-rpms/bouncycastle.git#96bc4febadcf4cb405592b23fc86c30478718372
SummaryBouncy Castle Cryptography APIs for Java
DescriptionThe Bouncy Castle APIs currently consist of the following: - A lightweight cryptography API for Java and C#. - A provider for the Java Cryptography Extension (JCE) and the Java Cryptography Architecture (JCA). - A provider for the Java Secure Socket Extension (JSSE). - A clean room implementation of the JCE 1.2.1. - A library for reading and writing encoded ASN.1 objects. - Lightweight APIs for TLS (RFC 2246, RFC 4346) and DTLS (RFC 6347/ RFC 4347). - Generators for Version 1 and Version 3 X.509 certificates, Version 2 CRLs, and PKCS12 files. - Generators for Version 2 X.509 attribute certificates. - Generators/Processors for S/MIME and CMS (PKCS7/RFC 3852). - Generators/Processors for OCSP (RFC 2560). - Generators/Processors for TSP (RFC 3161 & RFC 5544). - Generators/Processors for CMP and CRMF (RFC 4210 & RFC 4211). - Generators/Processors for OpenPGP (RFC 4880). - Generators/Processors for Extended Access Control (EAC). - Generators/Processors for Data Validation and Certification Server (DVCS) - RFC 3029. - Generators/Processors for DNS-based Authentication of Named Entities (DANE). - Generators/Processors for RFC 7030 Enrollment over Secure Transport (EST). - A signed jar version suitable for JDK 1.4-1.15 and the Sun JCE.
Built byoc-bot
State complete
Volume DEFAULT
StartedTue, 11 Aug 2026 11:36:31 CST
CompletedTue, 11 Aug 2026 11:40:05 CST
Taskbuild (dist-oc9, /src-opencloudos-rpms/bouncycastle.git:96bc4febadcf4cb405592b23fc86c30478718372)
Extra{'source': {'original_url': 'git+https://gitee.com/src-opencloudos-rpms/bouncycastle.git#96bc4febadcf4cb405592b23fc86c30478718372'}}
Tags
dist-oc9
dist-oc9-compose
RPMs
src
bouncycastle-1.80-5.oc9.src.rpm (info) (download)
noarch
bouncycastle-1.80-5.oc9.noarch.rpm (info) (download)
bouncycastle-mail-1.80-5.oc9.noarch.rpm (info) (download)
bouncycastle-pg-1.80-5.oc9.noarch.rpm (info) (download)
bouncycastle-pkix-1.80-5.oc9.noarch.rpm (info) (download)
bouncycastle-tls-1.80-5.oc9.noarch.rpm (info) (download)
bouncycastle-util-1.80-5.oc9.noarch.rpm (info) (download)
Logs
noarch
installed_pkgs.log
hw_info.log
dnf.rpm.log
mock_config.log
dnf.librepo.log
root.log
mock_output.log
state.log
dnf.log
build.log
noarch_rpmdiff.json
Changelog * Fri Aug 07 2026 PkgAgent Robot <pkgagent@opencloudos.tech> - 1.80-5 - [Type] security - [DESC] Fix CVE-2026-59638, CVE-2026-59639 * Wed Aug 05 2026 PkgAgent Robot <pkgagent@opencloudos.tech> - 1.80-4 - [Type] security - [DESC] Fix CVE-2026-58061, CVE-2026-59640 * Wed Jul 22 2026 Zhao Zhen <jeremiazhao@tencent.com> - 1.80-3 - [Type] bugfix - [DESC] add Maven-style Provides for jdk15on/jdk18on coordinates so packages depending on mvn(org.bouncycastle:bc{prov,pkix,pg,util,mail,tls}-jdk15on) such as jgit can resolve their dependencies * Thu Jul 09 2026 PkgAgent Robot <pkgagent@opencloudos.tech> - 1.80-2 - [Type] security - [DESC] Fix CVE-2025-14813: G3413CTRBlockCipher unable to process more than 255 blocks correctly * Mon Jan 20 2025 Zhao Zhen <jeremiazhao@tencent.com> - 1.80-1 - updated to upstream 1.80 - fixed CVE-2023-33201 CVE-2024-34447 CVE-2024-30171 - rewrite building script * Thu Sep 26 2024 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.70-5 - Rebuilt for clarifying the packages requirement in BaseOS and AppStream * Fri Aug 16 2024 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.70-4 - Rebuilt for loongarch release * Fri Sep 08 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.70-3 - Rebuilt for OpenCloudOS Stream 23.09 * Fri Apr 28 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.70-2 - Rebuilt for OpenCloudOS Stream 23.05 * Tue Apr 25 2023 cunshunxia <cunshunxia@tencent.com> - 1.70-1 - initial build